Announcement

Collapse
No announcement yet.

Alsa works with radeon 2400 HD

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Alsa works with radeon 2400 HD

    Hello everybody!

    My radeon 2400 finally works with alsa.

    ##Hardware part:

    I've a motherboard with an hdmi output. I don't use it because i've a pci express radeon card, with an ati dongle dvi/hdmi.

    ##Software part:

    I've an opensuse 10.3 withalsa 1.0.16-hg-20080323.

    ##History:

    Kmix don't find the audio card from the pci express card. The hdmi audio motherboard card is detected, but juste with a button iec958.

    aplay -l give me:

    **** List of PLAYBACK Hardware Devices ****
    card 0: SB [HDA ATI SB], device 0: ALC883 Analog [ALC883 Analog]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: SB [HDA ATI SB], device 1: ALC883 Digital [ALC883 Digital]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
    Subdevices: 0/1
    Subdevice #0: subdevice #0


    I tried aplay -Dplughw:1,3 "test.wav", and sound finally work.

    ##Config modification:

    /etc/asound.conf:

    pcm.!default {
    type hw
    card 1
    device 3
    }
    ctl.!default {
    type hw
    card 1
    device 3
    }
    pcm.atihdmi {
    type hw
    card 1
    device 3
    }
    ctl.atihdmi {
    type hw
    card 1
    device 3
    }

    After a alsa restart, kaffeine works fine.

    Vlc shows me the device in the alsa part.

    Mplayer works fine in command line, but i can't use alsa in Mplayer Gui. Then, i've turn on arts, and i've sound in Mplayer Gui.

    ##Problems:

    Kmix doesn't show the right audio card. During the tests, i've put "hdmi" and not "atihdmi" in asound.conf. I had a problem with aplay, but Kmix shows "Ati R600" card, with a graduation wich i can't move down. How to resolve this problem?

    How to configure mplayer gui, to disable arts?



    I hope it will help someone.

    CinPoU
Working...
X