Announcement

Collapse
No announcement yet.

ATI HD 2400Pro no direct rendering (gentoo)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ATI HD 2400Pro no direct rendering (gentoo)

    Hello.

    I have a problem is an ATI HD 2400 Pro brand new video card connected in AGP to my computer.

    I can start X but I don't have any direct rendering and for some reason that I don't know fglrxinfo says I'm using the Mesa 3D Project Indirect rendering, though the opensource radeonhd driver is *not* installed...

    Also "lsmod | grep agp" doesn't return *anything*.

    I think it has something to do with DRI because whenever I activate it in my xorg.conf file X fails to start and the output has a backtrace. I've been on that problem for about five hours now so I really need help for this. Thanks in advance.

    My xorg.conf file:
    Code:
    Section "Module"
        Load        "freetype"
        Load        "glx"
    #    Load       "dri"
        Load        "dbe"
        Load        "extmod"
        Load        "type1"
    EndSection
     
    Section "Files"
        FontPath   "/usr/share/fonts/misc/"
        FontPath   "/usr/share/fonts/Type1/"
        FontPath   "/usr/share/fonts/100dpi/"
        FontPath   "/usr/share/fonts/75dpi/"
    EndSection
     
    Section "ServerFlags"
            Option  "standby time" "10"
            Option  "DefaultServerLayout" "Layout 1"
            Option "AIGLX"  "on"
    EndSection
     
    Section "InputDevice"
        Identifier  "Keyboard"
        Driver      "kbd"
        Option "AutoRepeat" "500 30"
        Option "XkbRules"   "xorg"
        Option "XkbModel"   "pc105"
        Option "XkbLayout"  "fr"
    EndSection
     
    Section "InputDevice"
        Identifier  "Mouse"
        Driver      "mouse"
    #    Option "Device"      "/dev/input/mice"
    #    Option "ZAxisMapping"   "4 5 6 7"
    #    Option "Emulate3Buttons"
    EndSection
     
    Section "Monitor"
        Identifier  "hp f1723"
    #    HorizSync   31.5 - 79.0
    #    VertRefresh 50-100
    EndSection
     
    Section "Device"
        Identifier  "ATI HD 2400 Pro"
        Driver     "fglrx"
        Option "DRI" "false"
        Option "UseFastTLS" "0"
        Option "BlockSignalsOnLock" "on"
        Option "ForceGenericCPU" "off"
        Option "KernelModuleParm" "agplock=0"
        Option "UseInternalAGPGART" "no"
        Option "XAANoOffscreenPixmaps" "true"
    EndSection
    #Section "Device"
    #    Identifier  "ATI HD 2400 Pro (OSD)"
    #    Driver      "radeonhd"
    #EndSection
     
    Section "Screen"
        Identifier  "Screen 1"
        Device      "ATI HD 2400 Pro"
        Monitor     "hp f1723"
        DefaultDepth 24
        Subsection "Display"
            Depth       24
            Modes       "1280x1024" "1024x768" "800x600" "640x480"
    #        ViewPort    0 0
        EndSubsection
    EndSection
     
    Section "ServerLayout"
        Identifier  "Layout 1"
        Screen      "Screen 1"
        InputDevice "Mouse" "CorePointer"
        InputDevice "Keyboard" "CoreKeyboard"
    EndSection
     
    Section "Extensions"
            Option "Composite" "Enable"
    EndSection
     
    Section "DRI"
            Mode 0666
    EndSection
    Here is the (huge) X11 log: http://rafb.net/p/4Y5Qsp72.html (I wasn't able to post it in this topic because it was too long (53181 characters but only 10000 are allowed).

    Thank you for any help!

    edit: Moderators, you might consider moving this topic to Linux Graphics/ AMD/ATI Linux
    Thanks
    Last edited by N-0-X; 02-01-2008, 10:45 PM. Reason: Modified the title and added a not for the moderators

  • #2
    Okay, I've finally advanced a little bit I think.
    Instead of compiling via-agp in the kernel, I compiled it as a module and now when I load it, I can actually start X with DRI enabled (it doesn't crash anymore).
    The only problem is the screen is completely black and even when I go back in a tty, the screen is just black...

    Comment


    • #3
      I almost have a victory here...
      I finally decided my self to move the file glesx.so somewhere else because actually, it might of been the source of the problem. Thanks to that, I can start X with DRI and (that's the "cherry on the cake") fglrxinfo no longer says "Mesa" but "ATI". That actually solves the problem but, not exactly.

      In fact, when I execute fglrxinfo, it gives me the three firsts lines and then the system crashes... (Thank gosh for Alt+System+REISUB).
      That actually happens for anything which used GLX (like glxgears).

      Comment


      • #4
        See: http://phoronix.com/forums/showthrea...3885#post23885

        Compiling via-agp as a module is something I hadn't looked into yet,
        but from what I can see on my Ubuntu 7.10 2.6.22-14 kernel, it IS a module.

        Comment


        • #5
          The bug is already on the ATi bugzilla: http://ati.cchtml.com/show_bug.cgi?id=989
          It seems that some things can start working if you tweak the options...

          Comment


          • #6
            "But I don't want to tweak the options, I just want a driver that WORKS with my shiny new 150+ AGP card."

            Oh well .... *sigh*.... radeonhd is looking better and better lately.

            Comment


            • #7
              How good is radeonhd looking? Does it use the hardware HD decoder? That's all I want...

              Comment


              • #8
                I haven't done anything with HD on my 2600XT AGP yet, so I can't comment to that.
                radeonhd at the moment is JUST a display driver - it displays my desktop in 24 bit colour. That's it.
                There's no 3d Acceleration, not even 2d acceleration (still, it's faster on my system than fglrx without DRI) so if your CPU gets busy, video tearing is occasionally visible (and you have to use the x11 (Ximage/shm) video port to play back in Mplayer or derivatives).

                2d acceleration is around the corner, with 3d likely following close behind, but radeonhd can't hold a candle yet to the features I got used to when I had an NVidia 6600 GT card in my system.

                Still, radeonhd is the best option available to me right now, for my HD2600XT AGP. Most important for me under Linux is to be able to work on photo-editing, e-mail and internet browsing and with radeonhd, I can do that.

                Comment


                • #9
                  Okay.
                  I'll try to compare the radeonhd driver and the tweaked fglrx that I use for the moment (I enabled DRI in my xorg.conf but moved the file glesx.so so I could start up X).

                  For the moment, every graphical application is very slow, even when I move a window around in Fluxbox (the repait takes like two seconds and flickers)!

                  Comment


                  • #10
                    http://www.phoronix.com/scan.php?pag...item=843&num=1 in case you have trouble finding it. Current version on git should be 1.1.0

                    Comment


                    • #11
                      The AMD/ATI website says that HD2400 have an AVIVO chip (which is why I got a 2400HD card) so maybe should I use the Avivo driver instead of the fglrx "normal" one.
                      A tutorial is online: http://www.phoronix.com/scan.php?pag...item=777&num=1

                      I'll try that next week (because I don't have access to my so-called HD-Box until then).

                      Comment


                      • #12
                        Okay, so I got to try the radeonhd and avivo drivers.
                        The Radeonhd doesn't support "Component" plugin yet (or at least, that is what Gentoo's manual says (man radeonhd), I used Portage), so it totally useless to me as my computer is plugged-into my HDTV though the Component (viva real hd!). So when I try to start X, radeonhd simply says it found screens but none are usable.
                        About the Avivo driver, when I went on their webpage, the last commit was Thu, 4 Oct 2007, so it seems kind of a dead project... (http://gitweb.freedesktop.org/?p=avi....git;a=summary).

                        Then, I reinstalled fglrx to see if any changes were made in a week but I still get the Glesx.so problem (backtrace and all that crap).

                        Finally, I decided to boot under windows XP and try to get the latests ATI/AMD drivers. So, I got on their website, go to download the one for the 2400HD card and see: "Driver for 2400HD (PCIe only)". Great! ATI didn't even make a driver for the AGP card yet!!! Woohoo! Kudos for ATI! They sell a card for which they didn't even make drivers for!! Now how f**king useless is that?! What a rip-off!
                        Dang, this is the first and last time I *ever* make a mistake like this one: buying an ATI graphic card...

                        Comment


                        • #13
                          There was a hotfix driver published recently for HD2xxx AGP Windows products. Please reply back here if you don't find the link.

                          We're working on the same support for Linux.

                          Comment


                          • #14
                            Oh, sorry, I wasn't aware of the hotfix. All I did was go on the AMD website, click on "ati drivers" (or something like that) then "get the latest drivers" and there wasn't any mention of 2400HD AGP version.
                            Anyways, I googled it and fell here: http://support.ati.com/ics/support/d...estionID=29837

                            That didn't help at all. When I lanuch the setup, everything seems to work correctly then a nice error says that my "video or my operating system is not supported. Setup will exit." (It something along that line, I've just translated it from French). That is same error message I got with catalyst 8.something I tried to install yesterday (not knowing there was any hotfix)...
                            I suppose that is not the correct link since it doesn't work.

                            Comment


                            • #15
                              That link seems to go to an older driver (7.9). Give me a minute...
                              Last edited by bridgman; 02-09-2008, 01:26 PM.

                              Comment

                              Working...
                              X