Announcement

Collapse
No announcement yet.

ATI x1300 fglrx driver Ubuntu

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ATI x1300 fglrx driver Ubuntu

    has anyone had any real success with the fglrx driver on Ubuntu? I'm using it, Compiz is working but anything that uses gl just crashes X.

    My card is a PowerColor ATI x1300 512Mb and the relevant sections of my (current) xorg.conf looks like this:


    Section "Monitor"
    Identifier "aticonfig-Monitor[0]"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "Generic Video Card"
    Driver "fglrx"
    Busid "PCI:2:0:0"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"
    Option "Capabilities" "0x00000800"
    Option "UseFastTLS" "2"
    Option "KernelModuleParm" "locked-userpages=0"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "Generic Video Card"
    Monitor "CMC 19AW"
    Defaultdepth 24
    SubSection "Display"
    ****

    Ommitting display depths here...



    Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    Defaultdepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

    Section "Extensions"
    Option "Composite" "1"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "off"
    EndSection

  • #2
    Originally posted by mistermax View Post
    has anyone had any real success with the fglrx driver on Ubuntu? I'm using it, Compiz is working but anything that uses gl just crashes X.
    Maybe you could be a bit more specific about which opengl programs that crash with your fglrx driver?

    Comment


    • #3
      Originally posted by teroedni View Post
      Maybe you could be a bit more specific about which opengl programs that crash with your fglrx driver?
      Sure thing-

      currently on my machine and crashing x are:
      Briquolo
      Crack Attack
      Tremulous
      Google Earth

      other applications that run, but really poorly include xmame, dvd playback etc.

      display: :0.0 screen: 0
      OpenGL vendor string: ATI Technologies Inc.
      OpenGL renderer string: Radeon X1300 / X1550 Series
      OpenGL version string: 2.0.6958 Release

      Comment


      • #4
        have you tried disabled compiz to see if that causes the problems?

        And about dvd playback being slow. Have you installed all the codecs nessesary for it to work?


        Here is a great page explaining that part
        https://help.ubuntu.com/community/Re...ight=%28dvd%29
        Last edited by teroedni; 12-18-2007, 12:36 PM.

        Comment


        • #5
          I take it you're using XGL? OpenGL apps. will cause problems if both are used at the same time, the same goes for any full screen rendering (unless the cards is beefy enough).

          Comment


          • #6
            Yes I've got the Codecs; I've been using MPlayer, then Totem and more recently VLC for some time now (probably about 4 years), so when I set up a machine one of the first things I configure is the codec support. Thanks though.

            I believe I am using XGL, yes.

            Is it basically down to a choice between having compiz or having 3D applications? If so it really isn't a great choice. As for beefy, well the x1300 isn't top of the line, no, but it should be sufficient for most tasks.. http://www.elitebastards.com/cms/ind...ask=view&id=26

            Comment


            • #7
              Could be the same problem as me

              http://www.phoronix.com/forums/showthread.php?t=6958

              type

              Code:
              fglrxinfo -display :0
              and

              Code:
              fglrxinfo -display :1
              If you get overly different outcomes, then it's the same problem as I.

              Comment


              • #8
                Originally posted by mistermax View Post
                Yes I've got the Codecs; I've been using MPlayer, then Totem and more recently VLC for some time now (probably about 4 years), so when I set up a machine one of the first things I configure is the codec support. Thanks though.

                I believe I am using XGL, yes.

                Is it basically down to a choice between having compiz or having 3D applications? If so it really isn't a great choice. As for beefy, well the x1300 isn't top of the line, no, but it should be sufficient for most tasks.. http://www.elitebastards.com/cms/ind...ask=view&id=26
                There are always the newer drivers (current ones are 7.11), which let you use AIGLX for Compiz instead of XGL.

                Comment


                • #9
                  Thank for the help me.

                  Thank to you for the help me!


                  Edvin

                  __________________________________________________ _______
                  earning money

                  Comment


                  • #10
                    Originally posted by Tarmael View Post
                    Could be the same problem as me

                    http://www.phoronix.com/forums/showthread.php?t=6958

                    type

                    Code:
                    fglrxinfo -display :0
                    and

                    Code:
                    fglrxinfo -display :1
                    If you get overly different outcomes, then it's the same problem as I.
                    well, the output of that, with the latest driver, is like this:

                    max@scunner:~$ fglrxinfo -display :0
                    display: :0.0 screen: 0
                    OpenGL vendor string: ATI Technologies Inc.
                    OpenGL renderer string: Radeon X1300 / X1550 Series
                    OpenGL version string: 2.1.7170 Release

                    max@scunner:~$ fglrxinfo -display :0
                    max@scunner:~$ fglrxinfo -display :1
                    display: :1.0 screen: 0
                    OpenGL vendor string: Mesa project: www.mesa3d.org
                    OpenGL renderer string: Mesa GLX Indirect
                    OpenGL version string: 1.2 (2.1 Mesa 7.0.1)

                    Comment


                    • #11
                      You've probably got XGL installed.

                      Uninstall XGL I think it could be called, xserver-xgl.

                      If you have that installed, get rid of it, and make sure that AIGLX is enabled in your xorg.conf.

                      That was the biggest problem I had with the ATi drivers, doing that fixed it.

                      Cheers,

                      Bas.

                      Comment


                      • #12
                        That seemed to work; certainly I could start Termulous and CrackAttack, which (I believe) are both GL games.

                        That said, there is a bit of an annoying flicker - could this be my monitor refresh rate? Changing the settings in the Catalyst Control centre don't seem to make a difference.

                        Comment


                        • #13
                          Go to Preferences > Screen Resolution and see tinker with a few different settings there to find one that doesn't flicker maybe??

                          If you're using an older monitor, then a lower refresh rate is what you're after.

                          I'm using a 2004 model Dell monitor, running it at 1024x768 @ 85hz. It runs fine on my X1600.

                          CCC:LE I find it actually quite useless.

                          Maybe it'll have more use in a few releases.

                          I've had no issues with the graphics drivers since I worked out my problem (The XGL vs AIGLX thing)

                          Cheers,
                          Bas.

                          Comment


                          • #14
                            Originally posted by Tarmael View Post
                            Go to Preferences > Screen Resolution and see tinker with a few different settings there to find one that doesn't flicker maybe??

                            If you're using an older monitor, then a lower refresh rate is what you're after.

                            I'm using a 2004 model Dell monitor, running it at 1024x768 @ 85hz. It runs fine on my X1600.

                            CCC:LE I find it actually quite useless.

                            Maybe it'll have more use in a few releases.

                            I've had no issues with the graphics drivers since I worked out my problem (The XGL vs AIGLX thing)

                            Cheers,
                            Bas.
                            I'll check it out, although I'm using a half decent (generic) widescreen TFT I bought last year.

                            Comment


                            • #15
                              It isn't the monitor. When I try playing a gl game it is like a black/red flicker and (for want of a better word) scratchiness.

                              Comment

                              Working...
                              X