Announcement

Collapse
No announcement yet.

ATI x1300 fglrx driver Ubuntu

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    You've probably got XGL installed.

    Uninstall XGL I think it could be called, xserver-xgl.

    If you have that installed, get rid of it, and make sure that AIGLX is enabled in your xorg.conf.

    That was the biggest problem I had with the ATi drivers, doing that fixed it.

    Cheers,

    Bas.

    Comment


    • #12
      That seemed to work; certainly I could start Termulous and CrackAttack, which (I believe) are both GL games.

      That said, there is a bit of an annoying flicker - could this be my monitor refresh rate? Changing the settings in the Catalyst Control centre don't seem to make a difference.

      Comment


      • #13
        Go to Preferences > Screen Resolution and see tinker with a few different settings there to find one that doesn't flicker maybe??

        If you're using an older monitor, then a lower refresh rate is what you're after.

        I'm using a 2004 model Dell monitor, running it at 1024x768 @ 85hz. It runs fine on my X1600.

        CCC:LE I find it actually quite useless.

        Maybe it'll have more use in a few releases.

        I've had no issues with the graphics drivers since I worked out my problem (The XGL vs AIGLX thing)

        Cheers,
        Bas.

        Comment


        • #14
          Originally posted by Tarmael View Post
          Go to Preferences > Screen Resolution and see tinker with a few different settings there to find one that doesn't flicker maybe??

          If you're using an older monitor, then a lower refresh rate is what you're after.

          I'm using a 2004 model Dell monitor, running it at 1024x768 @ 85hz. It runs fine on my X1600.

          CCC:LE I find it actually quite useless.

          Maybe it'll have more use in a few releases.

          I've had no issues with the graphics drivers since I worked out my problem (The XGL vs AIGLX thing)

          Cheers,
          Bas.
          I'll check it out, although I'm using a half decent (generic) widescreen TFT I bought last year.

          Comment


          • #15
            It isn't the monitor. When I try playing a gl game it is like a black/red flicker and (for want of a better word) scratchiness.

            Comment


            • #16
              Well, I have no idea...

              Probably best to create a new thread.

              If you do start a new thread, I'll watch it in case I can help.

              Comment

              Working...
              X