Announcement

Collapse
No announcement yet.

Please help - fglrx black screen after pc cleanup

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Please help - fglrx black screen after pc cleanup

    Hi people!

    My Sapphire X1950pro 512mb AGP is showing black screen with fglrx after I've Pulled it out to clean my pc internals with compressed air.

    I've tried fglrx with Ubuntu 7.04 restricted fglrx driver and PClinuxOS 2007, and got the same results, but when I've installed the latest ATI's driver (8.38.6), It came back to life exept that OpenGL acceleration is disabled. No problems under VESA (exept that there's no acceleration) and windows xp is working perfectly!! (desktop,opengl,directx)
    Before that everything worked fine, I used to run Ubuntu 7.04 with restricted fglrx drivers w/OpenGL acceleration, I don't know what went wrong...
    Last edited by tsarig; 06-27-2007, 01:59 PM.

  • #2
    What is the output from cat /var/log/Xorg.0.log | grep EE
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Just a wild guess but does your /etc/X11/xorg.conf have:

      Code:
      Section "Extensions"
              Option  "Composite" "Disable"
      EndSection
      If it doesn't have that, try putting that in at the bottom of your xorg.conf and restart X. Also be sure to show us the logs like Michael pointed out.

      Comment


      • #4
        Thanks guys for the quick response

        Michael, I have no EE's @ /var/log/Xorg.0.log, I think you're missing the point, I've just plugged out the vga card, plugged in, and my troubles strated since then, I didn't messed up with none of the configuration files, or did anything in the software/system side, BUT, I had a TV card installed which I removed since then if that lead to any direction, anyway here's my /etc/X11/xorg.conf and the WW's of /var/log/Xorg.0.log:

        # /etc/X11/xorg.conf (xorg X Window System server configuration file)
        #
        # This file was generated by dexconf, the Debian X Configuration tool, using
        # values from the debconf database.
        #
        # Edit this file with caution, and see the xorg.conf(5) manual page.
        # (Type "man xorg.conf" at the shell prompt.)
        #
        # This file is automatically updated on xserver-xorg package upgrades *only*
        # if it has not been modified since the last upgrade of the xserver-xorg
        # package.
        #
        # If you have edited this file but would like it to be automatically updated
        # again, run the following command:
        # sudo dpkg-reconfigure -phigh xserver-xorg

        Section "Files"
        Fontpath "/usr/share/fonts/X11/misc"
        Fontpath "/usr/share/fonts/X11/cyrillic"
        Fontpath "/usr/share/fonts/X11/100dpi/:unscaled"
        Fontpath "/usr/share/fonts/X11/75dpi/:unscaled"
        Fontpath "/usr/share/fonts/X11/Type1"
        Fontpath "/usr/share/fonts/X11/100dpi"
        Fontpath "/usr/share/fonts/X11/75dpi"
        # path to defoma fonts
        Fontpath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        EndSection

        Section "Module"
        Load "i2c"
        Load "bitmap"
        Load "ddc"
        Load "dri"
        Load "extmod"
        Load "freetype"
        Load "glx"
        Load "int10"
        Load "vbe"
        EndSection

        Section "InputDevice"
        Identifier "Generic Keyboard"
        Driver "kbd"
        Option "CoreKeyboard"
        Option "XkbRules" "xorg"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "us,il"
        Option "XkbVariant" ","
        Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
        EndSection

        Section "InputDevice"
        Identifier "Configured Mouse"
        Driver "mouse"
        Option "CorePointer"
        Option "Device" "/dev/input/mice"
        Option "Protocol" "ImPS/2"
        Option "ZAxisMapping" "4 5"
        Option "Emulate3Buttons" "true"
        EndSection

        Section "InputDevice"
        Driver "wacom"
        Identifier "stylus"
        Option "Device" "/dev/input/wacom"
        Option "Type" "stylus"
        Option "ForceDevice" "ISDV4"# Tablet PC ONLY
        EndSection

        Section "InputDevice"
        Driver "wacom"
        Identifier "eraser"
        Option "Device" "/dev/input/wacom"
        Option "Type" "eraser"
        Option "ForceDevice" "ISDV4"# Tablet PC ONLY
        EndSection

        Section "InputDevice"
        Driver "wacom"
        Identifier "cursor"
        Option "Device" "/dev/input/wacom"
        Option "Type" "cursor"
        Option "ForceDevice" "ISDV4"# Tablet PC ONLY
        EndSection

        Section "Device"
        Identifier "Generic Video Card"
        Driver "fglrx"
        Busid "PCI:1:0:0"
        EndSection

        Section "Monitor"
        Identifier "BenQ FP73G"
        Option "DPMS"
        EndSection

        Section "Screen"
        Identifier "Default Screen"
        Device "Generic Video Card"
        Monitor "BenQ FP73G"
        Defaultdepth 24
        SubSection "Display"
        Depth 1
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
        EndSubSection
        SubSection "Display"
        Depth 4
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
        EndSubSection
        SubSection "Display"
        Depth 8
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
        EndSubSection
        SubSection "Display"
        Depth 15
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
        EndSubSection
        SubSection "Display"
        Depth 16
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
        EndSubSection
        SubSection "Display"
        Depth 24
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
        EndSubSection
        EndSection

        Section "ServerLayout"
        Identifier "Default Layout"
        screen "Default Screen"
        Inputdevice "Generic Keyboard"
        Inputdevice "Configured Mouse"
        Inputdevice "stylus" "SendCoreEvents"
        Inputdevice "cursor" "SendCoreEvents"
        Inputdevice "eraser" "SendCoreEvents"
        EndSection

        Section "DRI"
        Mode 0666
        EndSection

        Section "Extensions"
        Option "Composite" "Disable"
        EndSection

        Section "ServerFlags"
        Option "AIGLX" "off"
        EndSection



        (WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
        (WW) fglrx(0): board is an unknown third party board, chipset is supported

        Comment


        • #5
          hmm i had problems of lockups on my x1800 since 8.33.6 upon startup of X. 8.38.6 resolved them all.

          Comment


          • #6
            Guys I've solved it!! but this is so weird!!!!

            Just put back my TV card and everything is working again!!

            Comment

            Working...
            X