No announcement yet.

need help with new video card

  • Filter
  • Time
  • Show
Clear All
new posts

  • need help with new video card

    Hello everybody

    first of all I have to admit that I have very little knowledge about linux. Secondly I have started the same thread in but since nobody seems to be able to help me there, please forgive me for double posting this.

    My troubles started when I set up my new computer. I have installed Win7 and then ubuntu 9.4. Unlike in windows where the resolution of my screen (2048 x 1152) is correctly displayed, I cannot change the resolution in ubuntu above 1536 1152. My first attempt to resolve the problem was to install the "fglrx" driver. I used the package manager to do so and everything seemed to be ok until I tried to reboot the machine, which didnt work anymore (screen remains black). Since I was still able to boot in recovery mode I managed to somehow uninstall the driver and boot again in the normal mode. Next I installed the driver "radeonhd" which again went whitout any (visible) trouble, I also was able to boot thereafter. The only problem is now that I still cannot change the screen resolution.

    Conclusion: I need help with that.

    Thanks in advance for any attempt to help me solve my problem.

    -MoBo: gigabyte GA-MA770T-UD3P (AM3)
    -CPU: AMD PhenomII X3 720 BE
    -VideoCard: club3d hd5850
    -PSU: xigmatek GO GREEN (500Watt)

    PS: I do not need any 3d performance under ubuntu, just screen resolution.

  • #2
    Well with U 9.4 you can still use fglrx 9-9 driver. Login to vt1 (ctrl+alt+f1):

    sudo rm -f /etc/X11/xorg.conf*
    wget -N
    sudo sh
    fglrx should work but you get an ati unsupported logo. As soon as ati releases 9-10 final driver my script will be updated and the logo will not be there anymore. Just repeat those commands.


    • #3
      Does 9.9 support his GPU (HD 5850)?


      • #4
        The Cat 9.9 driver locked down before HD5xxx support was finalized, but it does work (with the caveats others have noticed, like the Unsupported Hardware watermark).

        The Cat 9.10 driver (ie this month's release) will be the first with full support.


        • #5
          Hello everybody

          first of all thanks a lot for trying to help me.
          If I want to try your solution kano but when I hit ctrl+alt+f1 it asks me to log in, but my password doesn't work (but it works for example when I log on the package manager).



          • #6
            you need the same username you usually use not root on ubuntu.


            • #7
              hello again

              ok, I managed to proceed as suggested. If I try to open the "display" window the following message appears:

              It appears that your graphics driver does not support the necessary extensions to use this tool. Do you want to use your graphics driver vendor's tool instead?

              If I click "no" then the window opens but I cannot change to the desired resolution (as before). If I click "ok" it is followed by a kind of "ati initialization error message" which also appears when I try to start catalyst control center. The message says something about the driver not working properly and that it should be fixed using aticonfig.



              • #8




                • #9
                  hi there again

                  when I open the console and just type in "fgl_glxgears" the following happens:

                  *******@*******-desktop:~$ fgl_glxgears
                  Using GLX_SGIX_pbuffer
                  X Error of failed request:  BadRequest (invalid request code or no such operation)
                    Major opcode of failed request:  135 (GLX)
                    Minor opcode of failed request:  19 (X_GLXQueryServerString)
                    Serial number of failed request:  16
                    Current serial number in output stream:  16
                  If I hit "ctrl+alt+f1" first and type it in then, it says something like:

                  couldn't open display(null)
                  thanks for your patience and your help!



                  • #10
                    Well it is clear that you can not use fgl_glxgears outside X. As soon as ati manages to put 9-10 really online i will update my script and you can try it again - basically you could use -v 9-10 option too, but the file must be there...