Announcement

Collapse
No announcement yet.

AMD Releases OpenCL ATI GPU Support For Linux

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Probably best to post on the Stream forum at developer.amd.com; that's where the Stream folks hang out. Don't think there has been much testing on Ubuntu 9.10 but that wouldn't explain the Unsupported Hardware icon; first thought is some kind of installation issue with the driver.

    Comment


    • #47
      There are 2 watermarks possible, one is unsupported hardware, that means you have to replace the /etc/control file and the other is a check for /etc/signature which is missing on beta drivers. You can take both files from any other driver.

      Comment


      • #48
        Good point, I forgot that beta drivers displayed the watermark. Thanks.

        Comment


        • #49
          But That wont solve my segmentation fault I guess. I don't care about the watermark actually. I just want the opencl driver to work.

          Comment


          • #50
            Yeah, the watermark was a red herring. I don't suppose you have a free partition to try it with Ubuntu 9.04, do you ?

            The SDK is a beta, tested on 9.04, and I would be surprised if it were trouble free on 9.10.

            Comment


            • #51
              Originally posted by bridgman View Post
              Yeah, the watermark was a red herring. I don't suppose you have a free partition to try it with Ubuntu 9.04, do you ?

              The SDK is a beta, tested on 9.04, and I would be surprised if it were trouble free on 9.10.
              I will se if I have time installing it on an external harddisk. But yes, it might be better running it on a supported OS :-)

              I created a thread on amd's developer forum. I can see other have the same problem, so I believe it will get fixed.

              Comment


              • #52
                Sounds good. There's nothing like running it on a supported configuration and still having a problem to get the developers attention

                Comment


                • #53
                  I still get the device unsupported, but opencl works. :-)

                  Though for some of the samples I get:
                  Error: Device does not support sub 32bit writes!

                  Well maybe my card just doesn't support 23bit writes.

                  Comment

                  Working...
                  X