Announcement

Collapse
No announcement yet.

Problem with 23 inch (1920x1200) Philips monitor in Linux and during bootup

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with 23 inch (1920x1200) Philips monitor in Linux and during bootup

    I was recently given a 23" monitor by Philips due to a warranty claim, but I am having trouble with it.

    My graphics card is nvidia 7900GT and I'm using the 185.18.14 version of nvidia-drivers. I should also mention that both the monitor and the graphics card have DVI-I ports. The monitor also has a VGA port.

    If I am connected using a single-link DVI-D cable to my Linux desktop then there is no image on the screen during bootup (i.e. the BIOS screen and subsequent Linux bootup screen). When the X server starts (and the nvidia drivers are loaded) then an image appears on the screen, however this is at a resolution of 640x400. From examining the /var/log/Xorg.0.log it becomes clear that the desktop is unable to read the EDID information from the monitor. Similarly the "Save EDID information" button in the nvidia-settings tool is not present.

    From /var/log/Xorg.0.log...
    Code:
    Unable to validate any modes; falling back to the default mode
    "nvidia-auto-select"
    I borrowed my flatmate's monitor (a 17" Sharp) and this works perfectly using the same DVI cable. The EDID information is readable, and the resolution is correctly detected. The BIOS bootup screens are visible.

    I have also tried the 23" Philips monitor with my Macbook (using the monitor's VGA port) and two Windows machines (also using VGA) and everything works perfectly (can see bootup and the resolution inside Windows is correctly determined).

    One further observation. On my Linux desktop, using nvidia-settings and looking under the "Flat panel information" bit, I see,
    Code:
    Chip location: internal
    Connection link: dual
    Signal: TMDS
    I am not using a dual-link DVI cable - I'm using a single-link cable... I thought that should be fine at a resolution of 1920x1200? This could be the nvidia-drivers getting confused however.

    Does anybody have any ideas as to what's up? I'm wondering there could be a broken DVI pin in the monitor's DVI port, or if I should be using a DVI-I cable, or if the EDID information is actually missing for some reason.

    Thank you,

    Erlend

  • #2
    Originally posted by erlend View Post
    I am not using a dual-link DVI cable - I'm using a single-link cable... I thought that should be fine at a resolution of 1920x1200?
    With reduced blanking at <=60 Hz, barely. Without, no.

    It's difficult to say if the GPU or cable or monitor is at fault here, all of those are common sources of problems.

    - If you dual-boot, check what happens using windows
    - try a different DVI cable. Many similar reports on the nvnews forums have been solved by switching to a different cable.
    - can you attach the 23" to your flatmate's computer to see what happens?
    - search for the monitor name/description here, on the nvnews forums or even google ("philips blabla linux"), maybe it's one of those broken monitors that requires manual modesetting

    I'd bet it's the cable, but maybe you want to check the other options before spending money on a dual-link cable that may or may not solve the problem.


    Edit: I just checked nvidia-settings here, my 24" 1600x1200 is connected with single-link, the 24" 1920x1200 with dual-link.
    Last edited by rohcQaH; 10-08-2009, 12:07 PM.

    Comment


    • #3
      What about getting a dual link cable?

      Comment


      • #4
        Originally posted by rohcQaH View Post
        With reduced blanking at <=60 Hz, barely. Without, no.
        I don't really know what that is...
        - If you dual-boot, check what happens using windows
        - try a different DVI cable. Many similar reports on the nvnews forums have been solved by switching to a different cable.
        I'll borrow one and give it a go.
        Originally posted by rohcQaH View Post
        - can you attach the 23" to your flatmate's computer to see what happens?
        I've done that, however I've only tested it using VGA (not DVI) since my flatmates computers only have VGA ports. On their machines, using the VGA port, it works perfectly.
        - search for the monitor name/description here, on the nvnews forums or even google ("philips blabla linux"), maybe it's one of those broken monitors that requires manual modesetting
        I've searched for it like crazy. The only thing I've found is that Philips large TVs have a problem. This is a deeper problem than just Linux drivers though - I'm not even seeing the BIOS bootup stuff on the monitor!

        I'd bet it's the cable, but maybe you want to check the other options before spending money on a dual-link cable that may or may not solve the problem.
        I have read that 1920x1200 monitors don't need dual-link DVI, but it could be wrong. BTW the monitor model is 230wp7ns.

        Edit: I just checked nvidia-settings here, my 24" 1600x1200 is connected with single-link, the 24" 1920x1200 with dual-link.
        If you can be bothered, and it's not too much trouble, would you mind trying to single-link cable in the 24" 1920x1200 dual-link please?

        Thanks for your replies.

        Comment


        • #5
          Well you could try this modeline (cvt -r 1920 1200 60):

          # 1920x1200 59.95 Hz (CVT 2.30MA-R) hsync: 74.04 kHz; pclk: 154.00 MHz
          Modeline "1920x1200" 154.00 1920 1968 2000 2080 1200 1203 1209 1235 +hsync -vsync

          And set res to 1920x1200. Of course you can try newer NV drivers as well - Kanotix users mainly use 190.36 now without problems.
          Last edited by Kano; 10-08-2009, 07:06 PM.

          Comment


          • #6
            Originally posted by erlend View Post
            If you can be bothered, and it's not too much trouble, would you mind trying to single-link cable in the 24" 1920x1200 dual-link please?
            Actually, I just checked my cables, they're both single-link. wtf? (they came with the monitors, I never bought any of my own.)

            Not seeing the BIOS might be a problem with your monitor taking too long to power up & set the resolution, I don't see anything on my second monitor until it's almost done booting either (unless I delay on grub or enter the bios menu).

            Try enabling Reduced Blanking in your xorg.conf, IIRC my 24" wasn't working right before I did, either. Can't copy/paste though because the computer is off, try google for instructions. If that doesn't work, try Kano's modeline. If that still doesn't work, get a new cable.

            Comment


            • #7
              Originally posted by Kano View Post
              Well you could try this modeline (cvt -r 1920 1200 60):

              # 1920x1200 59.95 Hz (CVT 2.30MA-R) hsync: 74.04 kHz; pclk: 154.00 MHz
              Modeline "1920x1200" 154.00 1920 1968 2000 2080 1200 1203 1209 1235 +hsync -vsync

              And set res to 1920x1200. Of course you can try newer NV drivers as well - Kanotix users mainly use 190.36 now without problems.
              Ok I've tried that, and also "UseEDID" "false" to force the mode to be used, but it isn't apparently valid so no luck.

              I think the problem is deeper than just the nvidia driver: I'm not getting anything on the screen at the BIOS stage of booting (i.e. before all drivers are loaded).

              I have just noticed the following in the /var/log/Xorg.0.log,
              Code:
              DFP-0: 330 MHz maximum pixel clock
              DFP-0: Internal Dual Link TMPS.
              Is this reliable? 330 MHz is dual-link, therefore if I can trust the xorg log then I should be using a dual-link cable.

              Comment


              • #8
                Originally posted by rohcQaH View Post
                Not seeing the BIOS might be a problem with your monitor taking too long to power up & set the resolution, I don't see anything on my second monitor until it's almost done booting either (unless I delay on grub or enter the bios menu).
                No, it's definitely not that: I can leave it forever at the grub screen and just never see anything. Further more I cannot see the consoles (TTY1,2,3...), the screen blanks when I go to those.

                However, if I connect my flatmate's DVI monitor (1280x1024) and then once everything is booted up nicely I switch to my 23" monitor (using DVI) things are better: the resolution is 1280x1024 (as the flatmate's monitor's EDID has prescribed) and I can switch to the TTY consoles.

                Comment


                • #9
                  And when you use a dvi->vga adapter till you get a working dvi cable?

                  Comment


                  • #10
                    interesting. I have a 7950 with a 24" Samsung DVI. Single link 1920x1200 and it works fine. Im on ubuntu 9.04 right now with supplied driver. On Ubuntu 9.10 it supplies 185, which worked equally.

                    Interesting concept you present. Trying different driver versions is always good.

                    Xorg log tells me:

                    Code:
                    (--) NVIDIA(0): Samsung SyncMaster (DFP-0): 330.0 MHz maximum pixel clock
                    (--) NVIDIA(0): Samsung SyncMaster (DFP-0): Internal Dual Link TMDS
                    so i doubt its the cable.

                    ...
                    wait...
                    TMDS
                    TMPS
                    Last edited by L33F3R; 10-09-2009, 01:14 PM.

                    Comment


                    • #11
                      Originally posted by Kano View Post
                      And when you use a dvi->vga adapter till you get a working dvi cable?
                      Interestingly, that doesn't work. I can use the VGA cable with another computer and everything seems to be fine (I can increase the screen resolution to 1920x1200), however when I put an adapter (VGA->DVI) on the cable and plug that into my graphics card's DVI port Xorg complains that the EDID information is corrupt.

                      To summarise briefly, if I use DVI to desktop I get no image on the screen during boot, only once the nvidia drivers kick in do I see something on the scren (and this is at a low resolution 640x480). Xorg.0.log complains that the EDID information has a corrupt header. If I use the VGA cable with other computers (laptops and windows desktops) then everything is ok - I can right click the desktop and increase the resolution to 1920x1200). If I put a VGA->DVI converter on the VGA cable and connect this to my desktop I get problems again (I do see output during boot, but I'm still getting a corrupted EDID).

                      I think it may be the graphics card.

                      Comment


                      • #12
                        Yes, best replace it and get a new series card with vdpau support. That would be better for videos anyway.

                        Comment


                        • #13
                          so have you tried manually providing an EDID or specifying the modeline yet?
                          If different computers can read the EDID, why don't you try dumping it on one of them?

                          What happens when you connect the monitor to the other output of your gfx card? If a pin is loose, that should solve it.

                          Your 7900gt seemed to work fine with your previous monitor, so I doubt it suddenly broke. Besides, acquiring the EDID is mostly a software task, not something with lots of hardware involved. Getting a new card may very well be a waste of a hundred bucks.

                          Comment


                          • #14
                            Originally posted by rohcQaH View Post
                            so have you tried manually providing an EDID or specifying the modeline yet?
                            If different computers can read the EDID, why don't you try dumping it on one of them?
                            I have not had success in getting another computer to read the EDID because I have only connected it to laptops (and they always return the EDID of the LCD screen attached to the laptop) or my flatmates desktop, which only has a VGA connector.

                            I tried setting the modeline as Kano suggested but the Xorg.0.log file says, "No valid modes found for 1920x1200". I also specified the UseEDID false and UseExactDVITimings True options.

                            Originally posted by rohcQaH View Post
                            What happens when you connect the monitor to the other output of your gfx card? If a pin is loose, that should solve it.
                            That doesn't help. Last night I also tried a different DVI-D cable. I also borrowed a DVI->VGA adapter to try the monitor on other machines - this worked fine (I could increase the resolution to 1920x1200).

                            Originally posted by rohcQaH View Post
                            Your 7900gt seemed to work fine with your previous monitor, so I doubt it suddenly broke. Besides, acquiring the EDID is mostly a software task, not something with lots of hardware involved. Getting a new card may very well be a waste of a hundred bucks.
                            I have read some stuff about minor incompatibilities between different DVI implementations. As for not seeing an image at bootup I wonder if the DVI EDID is stuck on sleep mode.

                            Comment


                            • #15
                              Originally posted by erlend View Post
                              I have not had success in getting another computer to read the EDID because I have only connected it to laptops (and they always return the EDID of the LCD screen attached to the laptop) or my flatmates desktop, which only has a VGA connector.
                              EDID works over VGA connectors, too. Also, nvidia-settings can dump the EDID of all connected monitors. If you only get the EDID of the internal LCD, that's a limitation of your dumping tool.

                              I'm not sure what xorg options you need to set to manually specify modelines. To override the EDID (once dumped), I did this:

                              Code:
                              Section "Screen"
                              	Option     "ConnectedMonitor"   "DFP-0,DFP-1"
                              	Option      "IgnoreDisplayDevices" "CRT, TV"
                              	Option     "CustomEDID" "DFP-0:/etc/X11/245B.edid; DFP-1:/etc/X11/214T.edid"
                              	...
                              I didn't need any further options. This is obviously for my dual-screen setup, adjust as needed.

                              Comment

                              Working...
                              X