No announcement yet.

OCZ Vertex 2 60GB SSD

  • Filter
  • Time
  • Show
Clear All
new posts

  • OCZ Vertex 2 60GB SSD

    Phoronix: OCZ Vertex 2 60GB SSD

    As solid-state drives are becoming very popular with enthusiasts and a common choice for those interested in high-performance data storage, at Phoronix we have reviewed many SSDs from OCZ Technology including the Agility, Agility EX, Vertex, and Solid 2. Today we are reviewing the next-generation Vertex SSD, which is the Vertex 2, and it promises to offer much faster reads and writes, is rated to last an extra 500,000 hours beyond the 1.5 million hour MTBF of the original Vertex, and is available in capacities up to 480GB.

  • #2
    A review of the RevoDrive would be very interesting (if you can get your hands on one)

    The OCZ website does not list linux compat. for that product, but the Sil3124 used should work out of the box and I wonder if you can have the two "drives" show up as two drives and use linux software raid on it.

    Also comparing linux software raid with the raid from the Sil (which also should be in software) would be interesting.


    • #3
      Is it possible to get benchmarks comparing ext4 and btrfs with different mount options on this drive?


      • #4
        You should do a benchmark on an Intel SSD sometime...


        • #5
          Please publish benchmarks comparing the Vertex 2 to the Intel MLC G2 SSD. I think a lot of people own the latter (as it's cheap and was said to have the best ssd controller for some time) and are considering an upgrade now.
          Different filesystems would be interesting, too :-)


          • #6
            Could someone clarify the differences between the Vertex 2 and Agility 2 models? They look the same to me ...

            AND: Please remove that stupid one minute timeout for edits -.-


            • #7
              IOPS in Vertex 2 are 50k.

              Agility 2 is limited up to 10k.

              I have a Vertex 2. quite happy, but Ubuntu disk utility shows the following error:


              Dont know if SMART tools are not ready to test SandForce controllers, but i'm a little worried. do you know any way to test it?


              • #8
                Problems with Vertex2

                I have the drive and two problems emerged:
                Running it on a Samsung NC20 doesnt work with fc13 and ext4, doesnt matter if LVM or not. Netboot install fails. Installation on a different computer - booting on NC20 fails. It works perfect with ext3, booting is not as fast as i expected it.

                And GUI disk utility (Gnome) reported nasty values for a block-reliability related SMART-interface, but this seems to be a firmware bug (no problems or data-loss happened).

                I recommend a modern SSD for Laptops. No noises, no vibrations, cool, very good speed. On a well-equiped desktop with a lot of RAM and running Linux, i had no massive speedup (but still noteable), due to cashing and Linux not being Windows.


                • #9
                  Is trim supported on Linux?

                  The cheapest SandForce drive is 40GB from OWC.

                  If space too small i can still add an 500GB HDD for file dump.


                  • #10
                    It's not clear from the article if all the drives were brand new or not. Especially for older drives without TRIM support (or ones that require an explicit tool to TRIM, if said tool hasn't been used), comparing a brand new out of the box drive with drives that have been used heavily during previous benchmarks will completely skew the results.


                    • #11
                      Usually you can update the firmware.


                      • #12
                        TRIM was added to Linux 2.6.33 (Feb 2010).

                        Please test again changing the i/o scheduler from cfq to noop...

                        cfq is good for servers with mechanical drives, noop for SSDs and deadline for desktop machines using mechanical drives (much better system/desktop responsiveness). Ubuntu uses cfq by default...

                        Also very important is to get rid of atime, meaning add noatime to the mount options in /etc/fstab, And no, relatime won't do, it will still write on every read, just a little later.


                        • #13
                          Originally posted by Viper_Scull View Post
                          Dont know if SMART tools are not ready to test SandForce controllers, but i'm a little worried. do you know any way to test it?
                          Support for SandForce controllers has been added to smartmontools about two weeks ago:


                          • #14
                            I've been thinking of getting a Vertex 2, but how reliable are they? Not the quoted numbers, but what are people's actual experiences? I know people close to me have had failures inside of six months (one of them had two go bad), so I'm a little worried that it might not just be freak coincidence. Anyone else heard anything like that? (Is it just what happens in Australia? )

                            I tried looking at customer feedback on Egg and Amazon, but it's just too sparse for my tastes (fewer than 100 just isn't even close to a good sample, IMO, much less fewer than 25).


                            • #15
                              do not buy! corrupts filesystem on suspend/resume

                              I bought the OCZ Vertex 2 120GB SSD drive after reading this positive review. Unfortunately, for laptops, the Vertex 2 series drives (and also these other drives that use SandForce controllers) have a major bug in their SandForce firmware (both v1.10 and v1.11): filesystem corruption upon resume from suspend to RAM!

                              When you resume your laptop from suspend to RAM, it wakes up to a corrupted filesystem. In my case, I was greeted with a blank X screen with mouse cursor (still responding to movement) but nothing else worked: I couldn't even switch out to a Linux virtual terminal (e.g. Ctrl-Alt-F1). The only course of action was to power down the system.

                              This problem has been reported on various forums and is known to occur in both Windows (people get BSOD) and Linux (what I described above).

                              Bottom line: Do not buy SSD drives with SandForce if you want to use it in laptops!